Menu

Star on GitHub · 3.4k

CVE-2026-110725

3.7 · LOW

fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js.

Published Oct 20, 2026CWE-41EPSS 0.30%

Overview

CVE-2026-110725 is a low-severity vulnerability. It was published on October 20, 2026 and has a CVSS 3.1 base score of 3.7 (LOW).

This vulnerability has a CVSS 3.1 base score of 3.7, rated LOW. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions before 2.4.8, from 3.0.0 through 3.1.8, and from 4.0.0 through 4.2.2, when serialize(), normalize(), or resolve() are called with the non-default option reference set to suffix on a reference that has no authority, the emitted relative reference can contain a bare colon in its first path segment without escaping it, even though RFC 3986 forbids that because it makes the string reparse as an absolute URI with a scheme. An application that serializes or normalizes a relative reference with the suffix option and then treats the result as a URI can turn inert input into a live javascript, data, or vbscript URL, a cross-site scripting vector, and the equal() comparison can conflate a scheme-bearing reference with a relative one. Exposure is limited to applications using the non-default suffix reference option. The issue is fixed in fast-uri 2.4.8, 3.1.9, and 4.2.3, and users should upgrade to one of th

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-110725?

CVE-2026-110725 is a low-severity vulnerability. It was published on October 20, 2026 and has a CVSS 3.1 base score of 3.7 (LOW).

How severe is CVE-2026-110725?

This vulnerability has a CVSS 3.1 base score of 3.7, rated LOW. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-110725?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-110725?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-110725 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related LOW CVEs from 2026

View all
LiveWatch live →