Menu

Star on GitHub · 3.4k

CVE-2026-112085

8.2 · HIGH

webpack-dev-server is a development server that provides live reloading for webpack projects.

Published Oct 22, 2026webpack.jsCWE-346EPSS 0.15%

Overview

CVE-2026-112085 is a high-severity vulnerability affecting webpack.js webpack-dev-server. It was published on October 22, 2026 and has a CVSS 3.1 base score of 8.2 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.2, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

webpack-dev-server is a development server that provides live reloading for webpack projects. In versions before 5.2.7 and in version 6.0.0, when a proxy entry is configured to forward WebSockets, the server forwards non-HMR WebSocket upgrade requests to the proxy target without validating the Host or Origin headers, so the allowedHosts protection does not apply to those proxied upgrades. A malicious web page visited by a developer can open a cross-origin WebSocket through the dev server and read from and write to the proxied backend, even when the server is bound to loopback. The issue is fixed in webpack-dev-server 5.2.7 and 6.1.0, where proxied WebSocket upgrades pass the same Host and Origin validation as the HMR WebSocket, and users should upgrade to one of those versions or later. As a workaround, omit WebSocket forwarding from proxy entries that do not need it and scope the proxy to specific paths.

Remediation

Check the references section for vendor advisories and patches from webpack.js. Update webpack-dev-server to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
webpack.jswebpack-dev-server>= 0, < 5.2.7Affected

Frequently asked questions

What is CVE-2026-112085?

CVE-2026-112085 is a high-severity vulnerability affecting webpack.js webpack-dev-server. It was published on October 22, 2026 and has a CVSS 3.1 base score of 8.2 (HIGH).

How severe is CVE-2026-112085?

This vulnerability has a CVSS 3.1 base score of 8.2, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-112085?

Check the references section for vendor advisories and patches from webpack.js. Update webpack-dev-server to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-112085?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-112085 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →