Menu

Star on GitHub · 3.4k

CVE-2026-112892

7.5 · HIGH

Pillow is a Python imaging library.

Published Oct 19, 2026pythonCWE-409EPSS 0.50%

Overview

CVE-2026-112892 is a high-severity vulnerability affecting python pillow. It was published on October 19, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Pillow is a Python imaging library. From 4.1.0 until 13.0.0, Pillow's MSP RLE decoder can expand a small file into an unbounded in-memory buffer. The decoder writes run-length output to BytesIO without limiting expansion to the declared image size. An attacker can supply a crafted MSP image to an application that loads its pixels. This can exhaust memory and deny service even when the declared pixel count passes the decompression-bomb check. This issue is fixed in version 13.0.0.

Remediation

Check the references section for vendor advisories and patches from python. Update pillow to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
pythonpillow>= 4.1.0, < 13.0.0Affected

Frequently asked questions

What is CVE-2026-112892?

CVE-2026-112892 is a high-severity vulnerability affecting python pillow. It was published on October 19, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

How severe is CVE-2026-112892?

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-112892?

Check the references section for vendor advisories and patches from python. Update pillow to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-112892?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-112892 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →