Menu

Star on GitHub · 3.4k

CVE-2026-112894

7.5 · HIGH

Pillow is a Python imaging library.

Published Oct 19, 2026pythonCWE-407EPSS 0.59%

Overview

CVE-2026-112894 is a high-severity vulnerability affecting python pillow. It was published on October 19, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Pillow is a Python imaging library. From 5.1.0 until 13.0.0, Pillow takes quadratic time to reserve PDF object identifiers when saving many frames with save_all enabled. PdfParser.next_object_id() repeatedly rebuilds and scans all previously reserved identifiers for every object. An attacker can supply a multi-frame image, including a small APNG with a large declared frame count, to an application that converts it to a multipage PDF. This can consume excessive CPU and deny service. This issue is fixed in version 13.0.0.

Remediation

Check the references section for vendor advisories and patches from python. Update pillow to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
pythonpillow>= 5.1.0, < 13.0.0Affected

Frequently asked questions

What is CVE-2026-112894?

CVE-2026-112894 is a high-severity vulnerability affecting python pillow. It was published on October 19, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

How severe is CVE-2026-112894?

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-112894?

Check the references section for vendor advisories and patches from python. Update pillow to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-112894?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-112894 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →