Menu

Star on GitHub · 3.4k

CVE-2026-41870

8.8 · HIGH

Missing Authorization, Improper Control of Generation of Code ('Code Injection'), Improper Control of Dynamically-Managed Code Resources, Use of Externally-Controlled Input to Select Classes or Cod…

Published Sep 9, 2026apacheCWE-94EPSS 0.66%

Overview

CVE-2026-41870 is a high-severity vulnerability affecting apache nutch. It was published on September 9, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Missing Authorization, Improper Control of Generation of Code ('Code Injection'), Improper Control of Dynamically-Managed Code Resources, Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Nutch Server (Nutch REST API).

This issue affects Apache Nutch: from 1.11 through 1.22.

Users are recommended to upgrade to version 1.23, which removes the Nutch Server.

If an upgrade is not possible, user must restrict access to instances running the Nutch Service to trusted users only.

Please, also visit the Apache Nutch security advisories https://nutch.apache.org/documentation/security/ .

Remediation

Check the references section for vendor advisories and patches from apache. Update nutch to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
apachenutch>= 1.11, < 1.23Affected

Frequently asked questions

What is CVE-2026-41870?

CVE-2026-41870 is a high-severity vulnerability affecting apache nutch. It was published on September 9, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

How severe is CVE-2026-41870?

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-41870?

Check the references section for vendor advisories and patches from apache. Update nutch to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-41870?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-41870 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →