Menu

Star on GitHub · 3.4k

CVE-2026-54238

3.1 · LOW

Supabase Realtime provides Broadcast, Presence, and Postgres Changes via WebSockets.

Published Oct 22, 2026CWE-613EPSS 0.21%

Overview

CVE-2026-54238 is a low-severity vulnerability. It was published on October 22, 2026 and has a CVSS 3.1 base score of 3.1 (LOW).

This vulnerability has a CVSS 3.1 base score of 3.1, rated LOW. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Supabase Realtime provides Broadcast, Presence, and Postgres Changes via WebSockets. Prior to version 2.103.1, the REST broadcast endpoints accept an expired JWT when the exp claim is encoded as a JSON string instead of a JSON number. The same route rejects an expired integer exp token signed with the same tenant secret. The accepted request returns 202 and emits the broadcast to subscribers. This could allow an unauthenticated attacker can broadcast realtime messages to subscribers. The attack can be performed via the Internet/only from within the supabase project. The impact of broadcasting messages to subscribers is application specific. This issue has been patched in version 2.103.1.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-54238?

CVE-2026-54238 is a low-severity vulnerability. It was published on October 22, 2026 and has a CVSS 3.1 base score of 3.1 (LOW).

How severe is CVE-2026-54238?

This vulnerability has a CVSS 3.1 base score of 3.1, rated LOW. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-54238?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-54238?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-54238 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related LOW CVEs from 2026

View all
LiveWatch live →