Menu

Star on GitHub · 3.4k

CVE-2026-54675

8.8 · HIGH

FreePBX is an open source IP PBX.

Published Sep 28, 2026sangomaCWE-22EPSS 0.66%

Overview

CVE-2026-54675 is a high-severity vulnerability affecting sangoma freepbx. It was published on September 28, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

FreePBX is an open source IP PBX. Prior to versions 16.0.10 and 17.0.5, a critical vulnerability exists in the sound language upload and conversion functionality that allows an authenticated attacker to perform arbitrary file writes, leading directly to remote code execution (RCE). Authentication with a known username is required. The vulnerability stems from insufficient path sanitization in the file conversion process, enabling path traversal attacks that place malicious PHP files in the web server's root directory. This issue has been patched in versions 16.0.10 and 17.0.5.

Remediation

Check the references section for vendor advisories and patches from sangoma. Update freepbx to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
sangomafreepbx>= 16.0, < 16.0.10Affected

Frequently asked questions

What is CVE-2026-54675?

CVE-2026-54675 is a high-severity vulnerability affecting sangoma freepbx. It was published on September 28, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

How severe is CVE-2026-54675?

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-54675?

Check the references section for vendor advisories and patches from sangoma. Update freepbx to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-54675?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-54675 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →