Menu

Star on GitHub · 3.4k

CVE-2026-55453

3.3 · LOW

OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems.

Published Oct 15, 2026openprintingCWE-74EPSS 0.19%

Overview

CVE-2026-55453 is a low-severity vulnerability affecting openprinting cups. It was published on October 15, 2026 and has a CVSS 3.1 base score of 3.3 (LOW).

This vulnerability has a CVSS 3.1 base score of 3.3, rated LOW. It requires local or adjacent network access to exploit. No authentication or special privileges are required for exploitation.

Technical description

OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to 2.4.20, the backend/ipp.c quote_string() function preserves carriage-return and line-feed characters in a remote printer-controlled marker-message before report_attr() writes the value to the scheduler status stream. The scheduler can parse an injected newline as a separate PPD: control line and persist an attacker-selected PPD keyword. The reporter demonstrated that a later print job on a Foomatic-backed queue could consume an injected FoomaticRIPCommandLine value and execute in the filter context as lp. This issue is fixed in version 2.4.20.

Remediation

Check the references section for vendor advisories and patches from openprinting. Update cups to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
openprintingcups>= 0, < 2.4.20Affected

Frequently asked questions

What is CVE-2026-55453?

CVE-2026-55453 is a low-severity vulnerability affecting openprinting cups. It was published on October 15, 2026 and has a CVSS 3.1 base score of 3.3 (LOW).

How severe is CVE-2026-55453?

This vulnerability has a CVSS 3.1 base score of 3.3, rated LOW. It requires local or adjacent network access to exploit. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-55453?

Check the references section for vendor advisories and patches from openprinting. Update cups to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-55453?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-55453 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related LOW CVEs from 2026

View all
LiveWatch live →