Menu

Star on GitHub · 3.4k

CVE-2026-57487

7.5 · HIGH

pupnp is an SDK for development of UPnP device and control point applications.

Published Oct 16, 2026pupnp_projectCWE-770EPSS 0.41%

Overview

CVE-2026-57487 is a high-severity vulnerability affecting pupnp_project pupnp. It was published on October 16, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

pupnp is an SDK for development of UPnP device and control point applications. Prior to 2.0.2, Transfer-Encoding: chunked causes the HTTP parser in upnp/src/genlib/net/http/httpparser.c to leave parser->content_length at zero while parser_parse_chunky_entity and parser_parse_chunky_body accumulate decoded bytes in parser->msg.entity. The g_maxContentLength checks in http_RecvMessage in upnp/src/genlib/net/http/httpreadwrite.c therefore reject oversized numeric Content-Length bodies but do not enforce the same limit on decoded chunked bodies. A remote peer that can reach a SOAP, GENA, miniserver, or control-point HTTP response path can make the process buffer an entity larger than the configured maximum, causing resource exhaustion and denial of service. This issue is fixed in 2.0.2.

Remediation

Check the references section for vendor advisories and patches from pupnp_project. Update pupnp to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
pupnp_projectpupnp>= 0, < 2.0.2Affected

Frequently asked questions

What is CVE-2026-57487?

CVE-2026-57487 is a high-severity vulnerability affecting pupnp_project pupnp. It was published on October 16, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

How severe is CVE-2026-57487?

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-57487?

Check the references section for vendor advisories and patches from pupnp_project. Update pupnp to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-57487?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-57487 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →