Menu

Star on GitHub · 3.4k

CVE-2026-59229

8.8 · HIGH

The Legacy Pipe receiver protocol (handshake / sendPipeData) uses a hardcoded SUPER_USER (root) identity when executing data loading and deletion operations.

Published Oct 21, 2026CWE-798EPSS 0.45%

Overview

CVE-2026-59229 is a high-severity vulnerability. It was published on October 21, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

The Legacy Pipe receiver protocol (handshake / sendPipeData) uses a

hardcoded SUPER_USER (root) identity when executing data loading and

deletion operations. A user with only SYSTEM-level privileges (such as

USE_PIPE or MAINTAIN) who does NOT have WRITE_DATA or DELETE_DATA

permissions on target databases can send specially crafted PipeData

messages through the Legacy Pipe API, resulting in data loading/deletion

operations executed as root — effectively bypassing IoTDB's permission

model entirely.

This issue affects Apache IoTDB: from 2.0.0 before 2.0.11.

Users are recommended to upgrade to version 2.0.11, which fixes the issue.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-59229?

CVE-2026-59229 is a high-severity vulnerability. It was published on October 21, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

How severe is CVE-2026-59229?

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-59229?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-59229?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-59229 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →