Menu

Star on GitHub · 3.4k

CVE-2026-61819

8.5 · HIGH

pg_partman is a PostgreSQL extension that manages partitioned tables by time or ID.

Published Sep 18, 2026CWE-89EPSS 0.73%

Overview

CVE-2026-61819 is a high-severity vulnerability. It was published on September 18, 2026 and has a CVSS 3.1 base score of 8.5 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.5, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

pg_partman is a PostgreSQL extension that manages partitioned tables by time or ID. Prior to 5.5.0, when pg_jobmon is installed and part_config.jobmon is true, exception handlers in multiple pg_partman functions place p_parent_table verbatim inside a SQL string literal used to call pg_jobmon.add_job(). A partman_user can create a parent-table name containing a single quote that terminates the literal and injects SQL when an affected exception path runs. If pg_partman_bgw reaches that path, the injected SQL executes with pg_partman_bgw.role privileges, which default to PostgreSQL superuser, permitting database-wide compromise and operating-system command execution as the PostgreSQL service account. The persistent part_config row can trigger the escalation again on later maintenance ticks. This issue is fixed in version 5.5.0.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-61819?

CVE-2026-61819 is a high-severity vulnerability. It was published on September 18, 2026 and has a CVSS 3.1 base score of 8.5 (HIGH).

How severe is CVE-2026-61819?

This vulnerability has a CVSS 3.1 base score of 8.5, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-61819?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-61819?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-61819 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →