Menu

Star on GitHub · 3.4k

CVE-2026-63498

8.7 · HIGH

Snipe-IT is an IT asset/license management system.

Published Sep 24, 2026snipeitappCWE-79EPSS 0.24%

Overview

CVE-2026-63498 is a high-severity vulnerability affecting snipeitapp snipe-it. It was published on September 24, 2026 and has a CVSS 3.1 base score of 8.7 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.7, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Snipe-IT is an IT asset/license management system. Prior to 8.7.0, the uploaded-files API endpoint GET /api/v1/{object_type}/{id}/files/{file_id} allows an authenticated user with file-management access to upload XML and XSLT attachments and request them with the inline=true parameter. The app/Http/Controllers/Api/UploadedFilesController.php show() path does not apply the safe-inline allowlist used by the equivalent web controller, so the browser can process an attacker-controlled xml-stylesheet reference and execute JavaScript generated by the stylesheet in the Snipe-IT origin. A victim who is authorized to view the object must open the attachment URL, after which the script can read same-origin data and perform authenticated actions with the victim's privileges. This issue is fixed in version 8.7.0.

Remediation

Check the references section for vendor advisories and patches from snipeitapp. Update snipe-it to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
snipeitappsnipe-it>= 0, < 8.7.0Affected

Frequently asked questions

What is CVE-2026-63498?

CVE-2026-63498 is a high-severity vulnerability affecting snipeitapp snipe-it. It was published on September 24, 2026 and has a CVSS 3.1 base score of 8.7 (HIGH).

How severe is CVE-2026-63498?

This vulnerability has a CVSS 3.1 base score of 8.7, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-63498?

Check the references section for vendor advisories and patches from snipeitapp. Update snipe-it to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-63498?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-63498 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →