Menu

Star on GitHub · 3.4k

CVE-2026-73547

7.5 · HIGH

Envoy is an open source edge and service proxy designed for cloud-native applications.

Published Sep 21, 2026envoyproxyCWE-20EPSS 0.55%

Overview

CVE-2026-73547 is a high-severity vulnerability affecting envoyproxy envoy. It was published on September 21, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to 1.36.10, 1.37.6, 1.38.4, and 1.39.1, Envoy's ext_authz filter assumes that a request contains a :path pseudoheader when applying query_parameters_to_set or query_parameters_to_remove from an authorization response. A path-less CONNECT request makes request_headers_->Path() return null, and Filter::onComplete dereferences that pointer while parsing the query string. An unauthenticated downstream client can crash the Envoy process when the filter and authorization response use query-parameter mutation. The relevant scope boundary is that the deployment must accept path-less CONNECT and configure ext_authz query-parameter mutation. This issue is fixed in versions 1.36.10, 1.37.6, 1.38.4, and 1.39.1.

Remediation

Check the references section for vendor advisories and patches from envoyproxy. Update envoy to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
envoyproxyenvoy>= 0, < 1.36.10Affected

Frequently asked questions

What is CVE-2026-73547?

CVE-2026-73547 is a high-severity vulnerability affecting envoyproxy envoy. It was published on September 21, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

How severe is CVE-2026-73547?

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-73547?

Check the references section for vendor advisories and patches from envoyproxy. Update envoy to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-73547?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-73547 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →