Menu

Star on GitHub · 3.4k

CVE-2026-74761

7.5 · HIGH

Improper input validation in TopicRegion in Apache ActiveMQ, Apache ActiveMQ Broker, and Apache ActiveMQ All on all platforms.

Published Sep 9, 2026apacheCWE-20EPSS 0.62%

Overview

CVE-2026-74761 is a high-severity vulnerability affecting apache activemq. It was published on September 9, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Improper input validation in TopicRegion in Apache ActiveMQ, Apache ActiveMQ Broker, and Apache ActiveMQ All on all platforms.

An authenticated client can spoof clientId when removing a durable topic subscription.

This issue affects Apache ActiveMQ Broker: before 5.19.11, from 6.0.0 before 6.3.2; Apache ActiveMQ All: before 5.19.11, from 6.0.0 before 6.3.2; Apache ActiveMQ: before 5.19.11, from 6.0.0 before 6.3.2.

Users are recommended to upgrade to version 6.3.2 or 5.19.11 which fixes the issue.

Remediation

Check the references section for vendor advisories and patches from apache. Update activemq to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
apacheactivemq>= 0, < 5.19.11Affected
apacheactivemq_all>= 0, < 5.19.11Affected
apacheactivemq_broker>= 0, < 5.19.11Affected

Frequently asked questions

What is CVE-2026-74761?

CVE-2026-74761 is a high-severity vulnerability affecting apache activemq. It was published on September 9, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

How severe is CVE-2026-74761?

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-74761?

Check the references section for vendor advisories and patches from apache. Update activemq to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-74761?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-74761 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →