Menu

Star on GitHub · 3.4k

CVE-2026-75600

8.8 · HIGH

FreePBX is an open source IP PBX.

Published Sep 28, 2026sangomaCWE-78EPSS 0.81%

Overview

CVE-2026-75600 is a high-severity vulnerability affecting sangoma freepbx. It was published on September 28, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

FreePBX is an open source IP PBX. Prior to version 17.0.9, authenticated users who are authorized to access the GraphQL api module interface of FreePBX are able to execute arbitrary shell commands. Authenticated access to the api module is required. The PBX API module's documentation generator accepts an authenticated host parameter and uses it to build a shell command. The code path validates the generated OAuth access token before execution, but it does not validate or escape host. Compromise results in authenticated arbitrary shell command execution as the FreePBX web/PBX service user (typically asterisk.). This issue has been patched in version 17.0.9.

Remediation

Check the references section for vendor advisories and patches from sangoma. Update freepbx to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
sangomafreepbx>= 0, < 17.0.9Affected

Frequently asked questions

What is CVE-2026-75600?

CVE-2026-75600 is a high-severity vulnerability affecting sangoma freepbx. It was published on September 28, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

How severe is CVE-2026-75600?

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-75600?

Check the references section for vendor advisories and patches from sangoma. Update freepbx to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-75600?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-75600 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →