Menu

Star on GitHub · 3.4k

CVE-2026-77271

8.8 · HIGH

MCP Atlassian is a Model Context Protocol (MCP) server for Atlassian products (Confluence and Jira).

Published Sep 22, 2026mcp-atlassianCWE-22EPSS 0.60%

Overview

CVE-2026-77271 is a high-severity vulnerability affecting mcp-atlassian mcp_atlassian. It was published on September 22, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

MCP Atlassian is a Model Context Protocol (MCP) server for Atlassian products (Confluence and Jira). Prior to 0.22.0, validate_safe_path defaults its base directory to os.getcwd(), and affected Confluence attachment call sites omit base_dir, allowing attacker-selected writes within the working directory. This Python module overwrite can provide code execution when the application later imports the modified module, bypassing the remediation tracked as CVE-2026-27825. This issue is fixed in version 0.22.0.

Remediation

Check the references section for vendor advisories and patches from mcp-atlassian. Update mcp_atlassian to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
mcp-atlassianmcp_atlassian>= 0, < 0.22.0Affected

Frequently asked questions

What is CVE-2026-77271?

CVE-2026-77271 is a high-severity vulnerability affecting mcp-atlassian mcp_atlassian. It was published on September 22, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

How severe is CVE-2026-77271?

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-77271?

Check the references section for vendor advisories and patches from mcp-atlassian. Update mcp_atlassian to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-77271?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-77271 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →