Menu

Star on GitHub · 3.4k

CVE-2026-77387

4.0 · MEDIUM

geopy is a geocoding library for Python.

Published Oct 1, 2026CWE-1333EPSS 0.20%

Overview

CVE-2026-77387 is a medium-severity vulnerability. It was published on October 1, 2026 and has a CVSS 3.1 base score of 4.0 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 4.0, rated MEDIUM. It requires local or adjacent network access to exploit. No authentication or special privileges are required for exploitation.

Technical description

geopy is a geocoding library for Python. Prior to 2.5.0, geopy.Point and Point.from_string() can spend excessive CPU time due to inefficient regular-expression behavior when an application passes a long malformed coordinate string without the 256-character input limit used by the fix. Geocoder reverse methods also reach the vulnerable parsing path when called with string inputs. Repeated attacker-controlled requests can cause a denial of service, while the numeric Point constructor is unaffected. This issue is fixed in version 2.5.0.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-77387?

CVE-2026-77387 is a medium-severity vulnerability. It was published on October 1, 2026 and has a CVSS 3.1 base score of 4.0 (MEDIUM).

How severe is CVE-2026-77387?

This vulnerability has a CVSS 3.1 base score of 4.0, rated MEDIUM. It requires local or adjacent network access to exploit. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-77387?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-77387?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-77387 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
LiveWatch live →