Menu

Star on GitHub · 3.5k

CVE-2026-77987

9.8 · CRITICAL

A server-side request forgery (SSRF) vulnerability was identified in the notebook viewer of GitHub Enterprise Server.

Published Sep 22, 2026githubCWE-208EPSS 0.88%

Overview

CVE-2026-77987 is a critical-severity vulnerability affecting github enterprise_server. It was published on September 22, 2026 and has a CVSS 3.1 base score of 9.8 (CRITICAL).

This vulnerability has a CVSS 3.1 base score of 9.8, rated CRITICAL. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

A server-side request forgery (SSRF) vulnerability was identified in the notebook viewer of GitHub Enterprise Server. The notebook viewer validated the scheme and host of a user-supplied URL but did not validate the port, allowing requests to be directed to internal services listening on other ports of the same appliance. Response bodies were not returned to the requester, but response timing acted as an oracle that allowed instance secrets to be extracted character by character. An extracted secret could then be used in a separate interaction with an internal service to obtain remote code execution on the appliance. Exploitation required network access to the instance and was unauthenticated when private mode was disabled, or required any authenticated user when private mode was enabled. This vulnerability affected GitHub Enterprise Server versions 3.17 through 3.22 and was fixed in versions 3.22.1, 3.21.6, 3.20.8, 3.19.12, 3.18.15, and 3.17.21. This vulnerability was reported through

Remediation

Check the references section for vendor advisories and patches from github. Update enterprise_server to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
githubenterprise_server>= 3.17.0, < 3.17.21Affected

Frequently asked questions

What is CVE-2026-77987?

CVE-2026-77987 is a critical-severity vulnerability affecting github enterprise_server. It was published on September 22, 2026 and has a CVSS 3.1 base score of 9.8 (CRITICAL).

How severe is CVE-2026-77987?

This vulnerability has a CVSS 3.1 base score of 9.8, rated CRITICAL. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-77987?

Check the references section for vendor advisories and patches from github. Update enterprise_server to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-77987?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-77987 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related CRITICAL CVEs from 2026

View all
CyberStrike v2 is here — more intelligence, greater reach