Menu

Star on GitHub · 3.4k

CVE-2026-80354

8.1 · HIGH

Authorization bypass through User-Controlled key vulnerability in Apache Camel K.

Published Sep 10, 2026apacheCWE-639EPSS 0.50%

Overview

CVE-2026-80354 is a high-severity vulnerability affecting apache camel. It was published on September 10, 2026 and has a CVSS 3.1 base score of 8.1 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.1, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Authorization bypass through User-Controlled key vulnerability in Apache Camel K.

An authorization vulnerability in custom resource resolution allows a tenant to reference secrets by name in the operator namespace, potentially exposing secrets belonging to other tenants or operator components.

This issue affects Apache Camel K: from 2.0.0 before 2.9.3, from 2.10.1 before 2.10.2.

Users are recommended to upgrade to version 2.9.3, 2.10.2 or 2.11.0, which fixes the issue.

Remediation

Check the references section for vendor advisories and patches from apache. Update camel to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
apachecamel>= 2.0.0, < 2.9.3Affected

Frequently asked questions

What is CVE-2026-80354?

CVE-2026-80354 is a high-severity vulnerability affecting apache camel. It was published on September 10, 2026 and has a CVSS 3.1 base score of 8.1 (HIGH).

How severe is CVE-2026-80354?

This vulnerability has a CVSS 3.1 base score of 8.1, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-80354?

Check the references section for vendor advisories and patches from apache. Update camel to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-80354?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-80354 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →