Menu

Star on GitHub · 3.4k

CVE-2026-81901

8.7 · HIGH

In Concrete CMS 9.2.0 through 9.5.2, the REST API page update endpoint (PUT /ccm/api/1.0/pages/{cID}) did not enforce page-property, page-template, or page-type authorization.

Published Sep 14, 2026concretecmsCWE-862EPSS 0.38%

Overview

CVE-2026-81901 is a high-severity vulnerability affecting concretecms concrete_cms. It was published on September 14, 2026 and has a CVSS 3.1 base score of 8.7 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.7, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

In Concrete CMS 9.2.0 through 9.5.2, the REST API page update endpoint (PUT /ccm/api/1.0/pages/{cID}) did not enforce page-property, page-template, or page-type authorization. A user granted only content-editing rights on a page could therefore alter its properties, template, and type through the API, and could set the header_extra_content attribute, which is rendered unescaped into the head element of every page, to persist JavaScript that executed in the browser of every visitor, including higher-privileged reviewers who approve the page version. The Concrete CMS security team gave this vulnerability a CVSS v4.0 score of 7.2 with vector CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N. Thanks Yonatan Drori from Tenzai for reporting.

Remediation

Check the references section for vendor advisories and patches from concretecms. Update concrete_cms to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
concretecmsconcrete_cms>= 9.2.0, < 9.5.3Affected

Frequently asked questions

What is CVE-2026-81901?

CVE-2026-81901 is a high-severity vulnerability affecting concretecms concrete_cms. It was published on September 14, 2026 and has a CVSS 3.1 base score of 8.7 (HIGH).

How severe is CVE-2026-81901?

This vulnerability has a CVSS 3.1 base score of 8.7, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-81901?

Check the references section for vendor advisories and patches from concretecms. Update concrete_cms to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-81901?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-81901 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →