Menu

Star on GitHub · 3.4k

CVE-2026-82377

9.9 · CRITICAL

Missing Authorization in Apache Roller 6.1.5 allows an authenticated user to read, modify, or delete weblog content belonging to other weblogs through the legacy XML-RPC Blogger and MetaWeblog APIs…

Published Sep 28, 2026CWE-862EPSS 0.41%

Overview

CVE-2026-82377 is a critical-severity vulnerability. It was published on September 28, 2026 and has a CVSS 3.1 base score of 9.9 (CRITICAL).

This vulnerability has a CVSS 3.1 base score of 9.9, rated CRITICAL. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Missing Authorization in Apache Roller 6.1.5 allows an authenticated user to read, modify, or delete weblog content belonging to other weblogs through the legacy XML-RPC Blogger and MetaWeblog APIs, because the handlers authenticate the caller but do not verify the caller's permission on the weblog or entry actually affected. Only installations that enable the non-default global XML-RPC setting are affected; the per-weblog API flag defaults to enabled for UI-created weblogs. Users are recommended to upgrade to Apache Roller 6.1.6 or later, which applies an explicit per-method permission check, or to keep the XML-RPC feature disabled.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-82377?

CVE-2026-82377 is a critical-severity vulnerability. It was published on September 28, 2026 and has a CVSS 3.1 base score of 9.9 (CRITICAL).

How severe is CVE-2026-82377?

This vulnerability has a CVSS 3.1 base score of 9.9, rated CRITICAL. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-82377?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-82377?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-82377 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related CRITICAL CVEs from 2026

View all
CyberStrike v2 is here — more intelligence, greater reach