Menu

Star on GitHub · 3.4k

CVE-2026-86243

7.5 · HIGH

Buffer over-read vulnerability in Apache Tomcat Native during the TLS handshake permits a malicious user to trigger a DoS via a JVM crash.

Published Sep 23, 2026apacheCWE-126EPSS 0.56%

Overview

CVE-2026-86243 is a high-severity vulnerability affecting apache tomcat_native. It was published on September 23, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Buffer over-read vulnerability in Apache Tomcat Native during the TLS handshake permits a malicious user to trigger a DoS via a JVM crash.

This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Earlier, unsupported versions may also be affected.

Users are recommended to upgrade to version 1.3.9 or 2.0.16, which fix the issue.

Remediation

Check the references section for vendor advisories and patches from apache. Update tomcat_native to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
apachetomcat_native>= 1.3.0, < 1.3.9Affected

Frequently asked questions

What is CVE-2026-86243?

CVE-2026-86243 is a high-severity vulnerability affecting apache tomcat_native. It was published on September 23, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

How severe is CVE-2026-86243?

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-86243?

Check the references section for vendor advisories and patches from apache. Update tomcat_native to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-86243?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-86243 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →