Menu

Star on GitHub · 3.4k

CVE-2026-88017

7.3 · HIGH

rclone is a command-line program to sync files and directories to and from different cloud storage providers.

Published Sep 10, 2026rcloneCWE-488EPSS 0.23%

Overview

CVE-2026-88017 is a high-severity vulnerability affecting rclone rclone. It was published on September 10, 2026 and has a CVSS 3.1 base score of 7.3 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.3, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

rclone is a command-line program to sync files and directories to and from different cloud storage providers. From 1.64.0 until 1.75.1, the FTP auth-proxy driver in cmd/serve/ftp/ftp.go stores one obscured password per username in the server-wide userPass map[string]string instead of binding the credential or VFS to the authenticated session. If two accepted credentials use the same username but resolve to different proxy backends, a later CheckPasswd login overwrites userPass[user], and subsequent getVFS operations on the first session are reauthorized with the later password. The first session can then read, create, overwrite, rename, or delete objects using the second credential’s backend authority. Exploitation requires the later same-username login to occur while the first session remains open. This issue is fixed in version 1.75.1.

Remediation

Check the references section for vendor advisories and patches from rclone. Update rclone to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
rclonerclone>= 1.64.0, < 1.75.1Affected

Frequently asked questions

What is CVE-2026-88017?

CVE-2026-88017 is a high-severity vulnerability affecting rclone rclone. It was published on September 10, 2026 and has a CVSS 3.1 base score of 7.3 (HIGH).

How severe is CVE-2026-88017?

This vulnerability has a CVSS 3.1 base score of 7.3, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-88017?

Check the references section for vendor advisories and patches from rclone. Update rclone to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-88017?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-88017 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →