Menu

Star on GitHub · 3.4k

CVE-2026-88064

8.8 · HIGH

Backstage is an open framework for building developer portals.

Published Sep 16, 2026linuxfoundationCWE-20EPSS 1.18%

Overview

CVE-2026-88064 is a high-severity vulnerability affecting linuxfoundation backstage_plugin-techdocs-node. It was published on September 16, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Backstage is an open framework for building developer portals. Prior to 1.14.6 and from 1.15.0 until 1.15.4, the @backstage/plugin-techdocs-node package insufficiently validates mkdocs.yml supplied by an authenticated user who can register or modify a TechDocs source. Unsafe Python YAML tags, markdown_extensions names and configuration, theme options, and extra_templates values can reach the documentation generator and cause unintended code execution. The resulting impact is limited to the files, credentials, network access, and other resources available to the TechDocs backend or build container. This issue is fixed in versions 1.14.6 and 1.15.4.

Remediation

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage_plugin-techdocs-node to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
linuxfoundationbackstage_plugin-techdocs-node>= 0, < 1.14.6Affected
linuxfoundationbackstage>= 0, < 1.14.6Affected

Frequently asked questions

What is CVE-2026-88064?

CVE-2026-88064 is a high-severity vulnerability affecting linuxfoundation backstage_plugin-techdocs-node. It was published on September 16, 2026 and has a CVSS 3.1 base score of 8.8 (HIGH).

How severe is CVE-2026-88064?

This vulnerability has a CVSS 3.1 base score of 8.8, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-88064?

Check the references section for vendor advisories and patches from linuxfoundation. Update backstage_plugin-techdocs-node to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-88064?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-88064 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →