Menu

Star on GitHub · 3.4k

CVE-2026-90580

6.3 · MEDIUM

A vulnerability was found in FlowiseAI Flowise up to 3.0.2.

Published Sep 13, 2026flowiseaiCWE-918EPSS 0.41%

Overview

CVE-2026-90580 is a medium-severity vulnerability affecting flowiseai flowise. It was published on September 13, 2026 and has a CVSS 3.1 base score of 6.3 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 6.3, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

A vulnerability was found in FlowiseAI Flowise up to 3.0.2. This vulnerability affects the function axios.post of the file packages/server/src/controllers/evaluations/index.ts of the component Evaluations Endpoint. The manipulation of the argument Host/X-Forwarded-Proto results in server-side request forgery. The attack may be launched remotely. The exploit has been made public and could be used. Upgrading to version 3.1.3 is able to resolve this issue. The patch is identified as 700137738bcaebefd4709021f6d6b0abcd7df0ac. It is recommended to upgrade the affected component. This vulnerability only affects products that are no longer supported by the maintainer.

Remediation

Check the references section for vendor advisories and patches from flowiseai. Update flowise to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
flowiseaiflowise>= 3.0.1, < 3.1.3Affected

Frequently asked questions

What is CVE-2026-90580?

CVE-2026-90580 is a medium-severity vulnerability affecting flowiseai flowise. It was published on September 13, 2026 and has a CVSS 3.1 base score of 6.3 (MEDIUM).

How severe is CVE-2026-90580?

This vulnerability has a CVSS 3.1 base score of 6.3, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-90580?

Check the references section for vendor advisories and patches from flowiseai. Update flowise to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-90580?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-90580 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
LiveWatch live →