Menu

Star on GitHub · 3.4k

CVE-2026-91852

6.1 · MEDIUM

Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Apache Sling XSS.

Published Sep 23, 2026apacheCWE-79EPSS 0.79%

Overview

CVE-2026-91852 is a medium-severity vulnerability affecting apache sling_xss_protection_api. It was published on September 23, 2026 and has a CVSS 3.1 base score of 6.1 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 6.1, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in Apache Sling XSS.

This issue affects Apache Sling XSS: before 2.4.12.

Users are recommended to upgrade to version 2.4.12, which fixes the issue.

Remediation

Check the references section for vendor advisories and patches from apache. Update sling_xss_protection_api to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
apachesling_xss_protection_api>= 0, < 2.4.12Affected

Frequently asked questions

What is CVE-2026-91852?

CVE-2026-91852 is a medium-severity vulnerability affecting apache sling_xss_protection_api. It was published on September 23, 2026 and has a CVSS 3.1 base score of 6.1 (MEDIUM).

How severe is CVE-2026-91852?

This vulnerability has a CVSS 3.1 base score of 6.1, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-91852?

Check the references section for vendor advisories and patches from apache. Update sling_xss_protection_api to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-91852?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-91852 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
LiveWatch live →