Menu

Star on GitHub · 3.4k

CVE-2026-91860

A prototype pollution vulnerability exists in the deep merge helpers of Vaadin Charts and Vaadin Component Base.

Published Sep 30, 2026CWE-1321EPSS 0.47%

Overview

CVE-2026-91860 is a known-severity vulnerability. It was published on September 30, 2026.

Technical description

A prototype pollution vulnerability exists in the deep merge helpers of Vaadin Charts and Vaadin Component Base. Merging an object the application does not control into a chart configuration or into a component's i18n property writes onto Object.prototype, making the injected properties visible to every object in the running application.

Users of affected versions should apply the following mitigation or upgrade. Releases that have fixed this issue include:

Product version

Vaadin 23.0.0 - 23.6.13

Vaadin 24.0.0 - 24.9.20

Vaadin 24.10.0 - 24.10.9

Vaadin 25.0.0 - 25.1.11

Vaadin 25.2.0 - 25.2.6

Mitigation

Upgrade to 23.6.14

Upgrade to 24.9.21

Upgrade to 24.10.10

Upgrade to 25.1.12

Upgrade to 25.2.7 or newer

Please note that Vaadin versions 10-13 and 15-22 are no longer supported and you should update either to the latest 23, 24, 25 version.

Artifacts

Maven coordinates Vulnerable versions Fixed version

com.vaadin:vaadin 23.0.0 - 23.6.13 >=23.6.14

com.vaadin:vaadin 24.0.0 - 24.9.20 >=2

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-91860?

CVE-2026-91860 is a known-severity vulnerability. It was published on September 30, 2026.

How severe is CVE-2026-91860?

CVSS score information is not yet available for this vulnerability. Check back as the CVE record is updated by NVD analysts.

How do I fix or remediate CVE-2026-91860?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-91860?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-91860 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

CyberStrike v2 is here — more intelligence, greater reach