Menu

Star on GitHub · 3.4k

CVE-2026-92587

5.0 · MEDIUM

n8n is a workflow automation platform.

Published Sep 16, 2026CWE-426EPSS 0.31%

Overview

CVE-2026-92587 is a medium-severity vulnerability. It was published on September 16, 2026 and has a CVSS 3.1 base score of 5.0 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 5.0, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

n8n is a workflow automation platform. In versions before 1.123.76, 2.37.7, and 2.38.2, the Git node validated a relative remote URL against the configured repositoryPath but then invoked git with that path as its working directory; git walked up to the enclosing repository's top level and resolved the same relative URL from there. An authenticated user (member) who nested the repository one level below the configured path could therefore make an identical URL string pass the file-access check while git resolved it outside the sandbox. A subsequent fetch or pull read a git repository outside N8N_RESTRICT_FILE_ACCESS_TO and merged its objects into the user's own repository, where their contents could be read back. The issue is fixed in n8n 1.123.76, 2.37.7, and 2.38.2, which resolve the remote reference from the directory git actually operates in before applying the sandbox check. As a workaround, the Git node can be disabled by adding n8n-nodes-base.git to NODES_EXCLUDE.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-92587?

CVE-2026-92587 is a medium-severity vulnerability. It was published on September 16, 2026 and has a CVSS 3.1 base score of 5.0 (MEDIUM).

How severe is CVE-2026-92587?

This vulnerability has a CVSS 3.1 base score of 5.0, rated MEDIUM. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-92587?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-92587?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-92587 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
LiveWatch live →