Menu

Star on GitHub · 3.4k

CVE-2026-92899

4.8 · MEDIUM

Apache WSS4J remembers the Nonce of each UsernameToken it accepts, so a captured token cannot be reused.

Published Sep 30, 2026apacheCWE-290EPSS 0.51%

Overview

CVE-2026-92899 is a medium-severity vulnerability affecting apache wss4j. It was published on September 30, 2026 and has a CVSS 3.1 base score of 4.8 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 4.8, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Apache WSS4J remembers the Nonce of each UsernameToken it accepts, so a captured token cannot be reused. It stored the Nonce as raw base64 text, but authentication decodes that text and uses the bytes.The same bytes can be written as base64 in several ways. An attacker who captured an authenticated request could re-send it with a space added to the Nonce: the password digest still verified, but the token no longer matched the remembered one, so the replay was accepted. Since a UsernameToken does not cover the message body, the captured token could then be reused on requests of the attacker's choosing until it expired. Affects deployments with a nonce replay cache configured, as Apache CXF has by default, and only tokens using a password digest. The cache is now keyed on the decoded Nonce. Users are recommended to upgrade to versions 4.0.2 or 3.0.6 or 2.4.4, which fix this issue.

Remediation

Check the references section for vendor advisories and patches from apache. Update wss4j to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
apachewss4j>= 0, < 2.4.4Affected

Frequently asked questions

What is CVE-2026-92899?

CVE-2026-92899 is a medium-severity vulnerability affecting apache wss4j. It was published on September 30, 2026 and has a CVSS 3.1 base score of 4.8 (MEDIUM).

How severe is CVE-2026-92899?

This vulnerability has a CVSS 3.1 base score of 4.8, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-92899?

Check the references section for vendor advisories and patches from apache. Update wss4j to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-92899?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-92899 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
LiveWatch live →