Menu

Star on GitHub · 3.4k

CVE-2026-92954

8.6 · HIGH

vm2 is a sandbox library for running untrusted JavaScript in Node.js.

Published Sep 17, 2026CWE-248EPSS 0.49%

Overview

CVE-2026-92954 is a high-severity vulnerability. It was published on September 17, 2026 and has a CVSS 3.1 base score of 8.6 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.6, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

vm2 is a sandbox library for running untrusted JavaScript in Node.js. In versions >= 3.10.0 and <= 3.11.7, Promises returned from the host realm into the sandbox are not marked as handled at the bridge boundary; only Promises created inside the sandbox are wrapped with a rejection-swallowing handler (lib/setup-sandbox.js), and the bridge only installs host-side rejection sanitizers when sandbox code calls .then/.catch/.finally. As a result, code running in the sandbox can invoke a host function that returns a rejected Promise (for example events.once() exposed via the NodeVM events builtin, or any embedder-provided Promise-returning API) and simply ignore the return value, leaving the host Promise unhandled so that Node.js's default unhandled-rejection behavior terminates the host process. This is an incomplete fix of GHSA-hw58-p9xv-2mjh. The issue is fixed in version 3.11.8.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-92954?

CVE-2026-92954 is a high-severity vulnerability. It was published on September 17, 2026 and has a CVSS 3.1 base score of 8.6 (HIGH).

How severe is CVE-2026-92954?

This vulnerability has a CVSS 3.1 base score of 8.6, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-92954?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-92954?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-92954 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →