Menu

Star on GitHub · 3.4k

CVE-2026-92958

8.5 · HIGH

vm2 through 3.11.6 contains a builtin-module denylist bypass in NodeVM.

Published Sep 17, 2026CWE-269EPSS 0.38%

Overview

CVE-2026-92958 is a high-severity vulnerability. It was published on September 17, 2026 and has a CVSS 3.1 base score of 8.5 (HIGH).

This vulnerability has a CVSS 3.1 base score of 8.5, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

vm2 through 3.11.6 contains a builtin-module denylist bypass in NodeVM. When the embedder uses the builtin wildcard together with negative entries (e.g. require: { builtin: ['*', '-fs', '-child_process'] }), negative entries are matched by exact module name in lib/builtin.js, so -fs removes only the builtin named fs and does not remove builtin subpaths such as fs/promises. Sandboxed code can therefore call require('fs/promises') or require('node:fs/promises') and reach the promise-based filesystem API despite fs being denied; node: prefix handling is likewise inconsistent (a -node:fs/promises entry does not block require('fs/promises')). Host file creation and writing were confirmed via fsp.writeFile(), and other fs/promises operations (cp, mkdir, rename, rm, rmdir, truncate, read operations, etc.) are also reachable. This issue is fixed in vm2 3.11.7.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-92958?

CVE-2026-92958 is a high-severity vulnerability. It was published on September 17, 2026 and has a CVSS 3.1 base score of 8.5 (HIGH).

How severe is CVE-2026-92958?

This vulnerability has a CVSS 3.1 base score of 8.5, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-92958?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-92958?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-92958 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →