Menu

Star on GitHub · 3.4k

CVE-2026-94484

4.8 · MEDIUM

Next.js is a React framework for building full-stack web applications.

Published Oct 2, 2026vercelCWE-524EPSS 0.24%

Overview

CVE-2026-94484 is a medium-severity vulnerability affecting vercel next.js. It was published on October 2, 2026 and has a CVSS 3.1 base score of 4.8 (MEDIUM).

This vulnerability has a CVSS 3.1 base score of 4.8, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Next.js is a React framework for building full-stack web applications. From 15.0.0 until 15.5.27 and 16.3.8, applications with a root-level catch-all page and statically generated or Incremental Static Regeneration routes can use a shared response cache key that is insufficiently scoped to the source route. A single unauthenticated crafted request can poison that cache, causing cross-user content substitution or persistent denial of service until the poisoned entry is revalidated or replaced. This issue is fixed in versions 15.5.27 and 16.3.8.

Remediation

Check the references section for vendor advisories and patches from vercel. Update next.js to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
vercelnext.js>= 15.0.0, < 15.5.27Affected

Frequently asked questions

What is CVE-2026-94484?

CVE-2026-94484 is a medium-severity vulnerability affecting vercel next.js. It was published on October 2, 2026 and has a CVSS 3.1 base score of 4.8 (MEDIUM).

How severe is CVE-2026-94484?

This vulnerability has a CVSS 3.1 base score of 4.8, rated MEDIUM. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-94484?

Check the references section for vendor advisories and patches from vercel. Update next.js to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-94484?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-94484 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related MEDIUM CVEs from 2026

View all
LiveWatch live →