Menu

Star on GitHub · 3.4k

CVE-2026-95847

7.5 · HIGH

Moquette is a lightweight Java MQTT broker.

Published Sep 23, 2026moquetteCWE-99EPSS 0.34%

Overview

CVE-2026-95847 is a high-severity vulnerability affecting moquette moquette. It was published on September 23, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Moquette is a lightweight Java MQTT broker. Prior to 0.18.1, H2PersistentQueue derives a session's message-map name as queue_ plus the client ID and its metadata-map name as queue_ plus the client ID plus _meta. A durable session whose client ID ends in _meta can therefore make its message map collide with another client's metadata map. The colliding sessions read and write the same H2 MVStore map with incompatible value types, which can corrupt queue head and tail data and cause message loss, misdelivery, failed queue reloads, or exposure of queued content across sessions. This issue is fixed in version 0.18.1.

Remediation

Check the references section for vendor advisories and patches from moquette. Update moquette to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
moquettemoquette>= 0, < 0.18.1Affected

Frequently asked questions

What is CVE-2026-95847?

CVE-2026-95847 is a high-severity vulnerability affecting moquette moquette. It was published on September 23, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

How severe is CVE-2026-95847?

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-95847?

Check the references section for vendor advisories and patches from moquette. Update moquette to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-95847?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-95847 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
LiveWatch live →